VRRP : Virtual Router Redundancy Protocol

The Virtual Router Redundancy Protocol (VRRP) is a computer networking protocol that provides for automatic assignment of available Internet Protocol (IP) routers to participating hosts. This increases the availability and reliability of routing paths via automatic default gateway selections on an IP subnetwork.

Communication between routers using virtual router ID and on the VRRP interface of each router is installed 1 IP address that is used as the local network Gateway. There are several routers that become gateways from one local network, then we can also do a ‘ priority ‘.

There is one router that can be used as the main gate and the other will be use a backup. VRRP that’s failed or we can call ‘ failover ‘, will be covered by another protocol as backup.

At some point when the main gateway is not only a fail line but also suffers damage to the device and will soon be supported by other devices without needing to do a new configuration of that router.

Example implementation

To more easily understand from this VRRP concept, we will try to do a simple network simulation. Use two routers connected to one Internet provider and become a local network Gateway. The network topology example is as follows.

Vrrp topology

Virtual router – With the topology above, we will configure in each router. For its configuration script as follows;

Virtual Main Router (RB750r2)

Adding the VRRP interface to the router

/interface vrrp
add interface=ether2 vrid=49 priority=254

Add IP Address on router interface

/ip address
add address=172.16.1.2/24 disabled=no interface=ether1 network=172.16.1.0/24
add address=192.168.2.1/24 disabled=no interface=ether2 network=192.168.2.0/24
add address=192.168.2.10/32 disabled=no interface=vrrp1 network=192.168.2.10

Virtual Router Backup (RB450)

Adding the VRRP interface to the router

/interface vrrp
add interface=ether2 vrid=49 priority=100

Add IP Address on router interface

/ip address
add address=172.16.1.3/24 disabled=no interface=ether1 network=172.16.1.0/24
add address=192.168.2.2/24 disabled=no interface=ether2 network=192.168.2.0/24
add address=192.168.2.10/32 disabled=no interface=vrrp1 network=192.168.2.10

Configuring the VRRP interface on each router, on the virtual router ID parameter (VIRD) must be likened to its value. Then on the Priority parameter, for the router as our main gateway setting with a value higher than the backup router. And we must also add a single IP address (with prefix/32) on the VRRP interface in each router that serves as the default client gateway on the local network.

About the author: One _e

Related Posts

Leave a Reply

Your email address will not be published. Required fields are marked *